header
Welcome Guest to ServerDoc - Auto Restart crashed servers and programs (game www ftp servers) with remote control panel
ServerDoc

· About ServerDoc
· Download/Purchase
· Getting Started
· User Guide
· Forums
· Feedback/Suggestion
· Mailing List
· Link To Us
· Your Account
· Linux


ServerDoc - Auto Restart crashed servers and programs (game www ftp servers) with remote control panel: Forums

Serverdoc :: View topic - php web interface
php web interface

 
Post new topic   Reply to topic    Serverdoc Forum Index -> Serverdoc
View previous topic :: View next topic  

Author Message
Threatcon



Joined: Oct 07, 2004
Posts: 23
Location: Florida

PostPosted: Wed Dec 10, 2008 12:26 am    Post subject: php web interface Reply with quote

I don't know what I'm doing wrong here at all.

I added this to my wwwconfig.cfg
Code:

user AllFromThisHost 74.220.206.41
user AllFromThisHost www.maxogc.net
user AllFromThisHost www.maxogc.com

That IP is my domains IP where the php script is running from. It is on a totally different server than ServerDoc.

I'm using $SDMode=1;

$SDUserName="Admin"; //not used because of the exceptions for the domain and IP in wwwconfig.cfg

Code:

$SDServers = array( array( 'xxx.xxx.xx.xx:25000', 'SD_ALL'),
           array( 'xxx.xxx.xx.xx:25001', 'SD_ALL'),
           );


I can get to the ServerDoc web pages individually without the php page via http://IP:Port, but they're not showing up on the php page. All I get is...
No access to serverdoc xxx.xxx.xx.xx:25000 check user AllFromThisHost x.x.x.x setting.
No access to serverdoc xxx.xxx.xx.xx:25001 check user AllFromThisHost x.x.x.x setting.


What am I missing? Do I need to add anything to template.html?


Last edited by Threatcon on Wed Dec 10, 2008 1:09 am; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website
Author Message
Threatcon



Joined: Oct 07, 2004
Posts: 23
Location: Florida

PostPosted: Wed Dec 10, 2008 12:31 am    Post subject: Reply with quote

I restarted ServerDoc on both IP and Ports I specified above. I didn't know if it was needed or not, but it didn't make a difference.

Added the domain in place of the IP and still not working.

I'm using Serverdoc V0.99b Pro
Back to top
View user's profile Send private message Visit poster's website
Author Message
sanderso
Site Admin


Joined: Jan 17, 2003
Posts: 1831

PostPosted: Wed Dec 10, 2008 5:30 am    Post subject: Reply with quote

Try the user AllFromThisHost setting with an IP address & not a hostname.

The IP required should be in serverdoc.log (if multihomed this can be a few)

also - ensure host has not blocked TCP for security/spam reasons.
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger MSN Messenger
Author Message
Threatcon



Joined: Oct 07, 2004
Posts: 23
Location: Florida

PostPosted: Wed Dec 10, 2008 3:16 pm    Post subject: Reply with quote

Quote:
The IP required should be in serverdoc.log (if multihomed this can be a few)

Yes I do have 6 IP's on that server, but only one is for ServerDoc.
No connections for the php page are showing in the log file at all for either ServerDoc setup. When I connect via http://IP:PORT I see it in the log though. I'll try connecting to one of the other IP's and see what happens.

Quote:
also - ensure host has not blocked TCP for security/spam reasons.

No clue how to configure that, but I'll Google it or something. If you know anything please post it. I have a Windows 2003 R2 server.
Back to top
View user's profile Send private message Visit poster's website
Author Message
sanderso
Site Admin


Joined: Jan 17, 2003
Posts: 1831

PostPosted: Wed Dec 10, 2008 6:29 pm    Post subject: Reply with quote

I was talking if the web server was multihomed.

If the serverdoc log is not showing incoming connection you need to check the php script is not firewalled/blocked - you could always add a "webpage" server in the script.
ie ive just added google.com:80 to my list of "serverdocs" in http://www.serverdoc.com/demo/sd_standalone2.php and now get google (minus the images as im not hosting them) page coming up.

(then if a webpage works check a connection to games server on port 80 as maybe the ports are blocked)
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger MSN Messenger
Author Message
Threatcon



Joined: Oct 07, 2004
Posts: 23
Location: Florida

PostPosted: Wed Dec 10, 2008 6:37 pm    Post subject: Reply with quote

Ok I'll try that when I get home.

Thanks.
Back to top
View user's profile Send private message Visit poster's website
Author Message
Threatcon



Joined: Oct 07, 2004
Posts: 23
Location: Florida

PostPosted: Thu Dec 11, 2008 12:02 am    Post subject: Reply with quote

Ok added Google.com:80 and it works just fine. I'm not seeing any blocked requests on the server from my site that is running the php script.

Will keep checking...
Back to top
View user's profile Send private message Visit poster's website
Author Message
Threatcon



Joined: Oct 07, 2004
Posts: 23
Location: Florida

PostPosted: Thu Dec 11, 2008 12:15 am    Post subject: Reply with quote

Ok got it.

In the command prompt I typed in netstat -a

That returned all the open ports on my server and who was connected/connecting to them at that time. I found my web host was trying to connect on ServerDoc's port number. Put in my hosts (hostmonster.com) in the allowed list and it didn't work. So I had to trace their domain name to an IP and add that one.

Works fine now! Whoot!!

Now just to password the directory with an .htaccess file and I'm good.

Thanks!
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Serverdoc Forum Index -> Serverdoc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2004 phpBB Group
Version 2.1 by Nuke Cops 2003 http://www.nukecops.com
TBlue by DR Designs © 2004

Forums ©
footer
Copyright 2004 serverdoc.com

Web site engine code is Copyright 2003 by PHP-Nuke All Rights Reserved PHP-Nuke is Free Software released under the GNU/GPL license